В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Русель
Русель
30.09.2020 19:55 •  Информатика

Напишите программу которая вычисляет площадь кольца , если его толщина t см, а радиус внутреннего круга d см (в паскале)

Показать ответ
Ответ:
LIONVIP
LIONVIP
03.04.2022 10:09

#include <iostream>

#include <string>

bool is_palindrome(const std::string& s) {

   std::string r(s);

   std::reverse(r.begin(), r.end());

   return s == r;

}

int main() {

   std::string s1,s2;

   setlocale(LC_ALL, "Russian");

   std::cout << "Введите число 1: ";

   std::getline(std::cin, s1);

   std::cout << "Введите число 2: ";

   std::getline(std::cin, s2);

   if (is_palindrome(s1)|| is_palindrome(s2))

       std::cout << "Одно из введенных чисел является палиндромом " << std::endl;

   else

       std::cout << "Ни одно из введенных чисел не является палиндромом " << std::endl;

   return 0;

}

0,0(0 оценок)
Ответ:
ksapko
ksapko
21.11.2021 19:01

Was a young man in love with a beautiful girl? What did the girl say to the young man one day? Where did a young man go? How old was the girl? How many roses did a man in the shopsencl?

Дополнен менее минуты назад

молодой человек был влюблен в красавицу. они очень часто встречались и много времени проводили вместе. они говорили об интересных книгах, фильмах о театральной работе. однажды девушка сказала молодому человеку: - завтра у меня день рождения. Вы придете, чтобы отпраздновать его с другими друзьями? -О, Конечно сказал молодой человек. - Но сначала я пришлю вам розы, - сказал один из продавцов, - чтобы вы послали их девушке на следующий день. Человек в магазине знал молодого человека очень хорошо, потому что он часто покупал цветы в своем магазине. ВОТ ПЕРЕВОД .

Объяснение:

Was a young man in love with a beautiful girl? What did the girl say to the young man one day? Where did a young man go? How old was the girl? How many roses did a man in the shopsencl?

Дополнен менее минуты назад

молодой человек был влюблен в красавицу. они очень часто встречались и много времени проводили вместе. они говорили об интересных книгах, фильмах о театральной работе. однажды девушка сказала молодому человеку: - завтра у меня день рождения. Вы придете, чтобы отпраздновать его с другими друзьями? -О, Конечно сказал молодой человек. - Но сначала я пришлю вам розы, - сказал один из продавцов, - чтобы вы послали их девушке на следующий день. Человек в магазине знал молодого человека очень хорошо, потому что он часто покупал цветы в своем магазине. ВОТ ПЕРЕВОД .

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота