В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Напишите программу, которая вычисляет количество цифр числа. используйте функцию.

Показать ответ
Ответ:
тимур624
тимур624
10.08.2020 18:28
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

function nDigits(n:int64):integer; // если число
begin
  Result:=0;
  if n<0 then n:=-n;
  while n>0 do begin
    Result+=1;
    n:=n div 10
    end
end;

function nDigits(s:string):=s.Length; // если строка

begin
  Writeln(nDigits(1234567890123456)); // 16
  Writeln(nDigits('123456789012345678901234567890')) // 30
end.

Результат
16
30
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота