В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
МихаилД
МихаилД
13.01.2023 06:30 •  Информатика

Напишите программу, которая вводит с клавиатуры три числа, и находит их сумму и произведение. (на языке Паскаль)​

Показать ответ
Ответ:
нануша456
нануша456
29.01.2021 19:30

var n, sum, mult: integer;

begin

write('Enter number: ');

readln(n);

sum := 0;

mult := 1;

while n > 0 do begin

sum := sum + n mod 10;

mult := mult * (n mod 10);

n := n div 10

end;

writeln('Sum of digits = ', sum);

writeln('Multiplication of digits = ', mult);

readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота