Напишите программу, которая вводит с клавиатуры 20 реальных чисел, и организовывает их хранение в массиве. после этого определяет сумму элементов, значение которых больше среднего арифметического элементов массива.
Const n=20; var x:array[1..n] of real; i:integer; s,sr:real; begin for i:=1 to n do begin write('x[',i,']='); readln(x[i]); end; s:=0; for i:=1 to n do s:=s+x[i]; sr:=s/n; s:=0; for i:=1 to n do if x[i]<sr then s:=s+x[i]; writeln('sr = ',sr,' s = ',s); end.
var x:array[1..n] of real;
i:integer; s,sr:real;
begin
for i:=1 to n do
begin
write('x[',i,']=');
readln(x[i]);
end;
s:=0;
for i:=1 to n do s:=s+x[i];
sr:=s/n;
s:=0;
for i:=1 to n do
if x[i]<sr then s:=s+x[i];
writeln('sr = ',sr,' s = ',s);
end.