В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Markizka22
Markizka22
14.11.2021 01:29 •  Информатика

Напишите программу, которая вводит натуральные числа a и b и выводит все простые числа в диапазоне от a до b . входные данные: входная строка содержит два натуральных числа, a и b . гарантируется, что a ≤ b . выходные данные программа должна вывести в одной строке через пробел все простые числа на отрезке [ a , b ] . если таких чисел нет, программа должна вывести 0.

Показать ответ
Ответ:
думка3
думка3
04.10.2020 10:02
Var
   a,b,d,K,kp:integer;
   P:boolean;
Begin
kp:=0;
ReadLn(a,b);
if (a = 1)or(a = 2) then
   Begin
   kp:=2;
   Write(2,' ',3)
   end
else if a = 3 then
        Begin
        kp:=1;
        Write(3);
        End;
if a < 5 then a:=5
else if a mod 2 = 0 then a:=a+1;
While a<=b do
   Begin
   K:=Trunc(Sqrt(A));
   d:=3;
   P:=true;
   While d <= K do
      Begin
      if A mod d = 0 then P:=false;
      d:=d+2
      End;
   if P then
      Begin
      kp:=kp+1;
      Write(' ',a);
      End;
   a:=a+2
   End;
if kp = 0 then Write(0)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота