В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
2003tanya
2003tanya
26.05.2023 00:22 •  Информатика

Напишите программу, которая вводит два числа a и n вычисляет a^n. програмный код. не через "power". заранее

Показать ответ
Ответ:
VLaDiSLaVVoRoNKoV
VLaDiSLaVVoRoNKoV
16.09.2020 17:16
Function Pow(a : Integer; b : Integer) : Integer;
Begin
  If b=0 then Pow:=1 else Pow:=a*Pow(a,b-1);
End;

Var A,N : Integer;
Begin
  Readln(A,N);
  Writeln(Pow(A,N));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота