В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kirushinad1
kirushinad1
16.03.2023 05:22 •  Информатика

Напишите программу, которая возводит в квадрат трехзначное число, введённое с клавиатуры, при условии, что в числе содержится цифра 7. если в числе нет цифры 7, то следует вывести число в исходном виде(через оператор if)паскаль

Показать ответ
Ответ:
Alenadobro97
Alenadobro97
02.08.2020 23:57
Var a:integer; s:string;
begin
 readln(a);
 str(a,s);
 if (pos('7',s)>0)
 then
   a:=a*a;
 writeln(a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота