В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
deniskalubit
deniskalubit
28.11.2021 02:51 •  Информатика

Напишите программу, которая возводит натуральное число a в натуральную степень b . входные данные входная строка содержит два числа, a и b , разделённые пробелом. гарантируется, что 1 ≤ a , b ≤ 1000 . выходные данные программа должна вывести одно число: a в степени b . примеры входные данные 2 6 выходные данные 64. паскаль abc 1.8

Показать ответ
Ответ:
annaelena261280
annaelena261280
05.10.2020 11:18
Program n1;
procedure st(n:longint; k: integer );
var i,m : longint;
begin
m:=n;
for i:=1 to k-1 do n:=n*m; writeln(n);
end;
var a,b: integer;
begin
readln(a,b);
if (a>=1) and (b<=1000) then st(a,b);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота