В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
новичок604
новичок604
25.03.2020 07:00 •  Информатика

напишите программу которая в последовательности чисел заканчивающуюся нулем определяет среднее арифметическое четных чисел кратных 3 и трехзначных, ПИТОН

Показать ответ
Ответ:
werasdfghjfdfd
werasdfghjfdfd
09.03.2021 17:05

summ = 0

count = 0

while 1:

   a = int(input())

   if a == 0:

       break

   elif len(str(abs(a))) == 3 and a % 2 == 0 and a % 3 == 0:

       summ += a

       count +=1

print(summ/count)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота