В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
TanushaGuda
TanushaGuda
23.09.2021 08:57 •  Информатика

Напишите программу, которая удаляет из строки все повторяющиеся символы. входные данные на вход программы подаётся строка, содержащая символы таблицы ascii. выходные данные программа должна вывести исходную строку, из которой удалены все повторяющиеся символы. примеры входные данные abc13a1b2z3c выходные данные abc132z входные данные qwasd123 выходные данные qwasd123 pascal abc 1.8

Показать ответ
Ответ:
dfghfgjkhfdjkgh
dfghfgjkhfdjkgh
05.10.2020 13:39

var str:string;i,n:integer;

begin

readln(str);

for i := 1 to length(str)-1 do

for n:=length(str) downto i+1 do

if str[n]=str[i]then delete(str,n,1);

writeln(str);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота