В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
art1610
art1610
14.09.2020 22:20 •  Информатика

Напишите программу, которая строит последовательность из n случайных чисел на отрезке от 0 до 1 и определяет, сколько из них попадает в полуинтервалы [0; 0,25], [0,25; 0,5), [0,5; 0,75) и [0,75; 1). сравните результаты, полученные при n=10,100, 1000, 10000. . надо!

Показать ответ
Ответ:
McVano
McVano
30.07.2020 06:56
На pascal abc net
program test;
type realarray = array of real;
var
  step:real;
  a:realarray;
  i,n,s1,s2,s3,s4:integer;
begin
  write('Введите количество членов последовательности: ');
  readln(n);
  step:=1/n;
  setlength(a,n);
  a[0]:=0;
  for i:=1 to n-1 do a[i]:=a[i-1]+step;
  for i:=0 to n-1 do begin
    if a[i]<0.25 then s1:=s1+1;
    if (a[i]>=0.25) and (a[i]<0.5) then s2:=s2+1;
    if (a[i]>=0.5) and (a[i]<0.75) then s3:=s3+1;
    if a[i]>=0.75 then s4:=s4+1;
  end;
  writeln('На промежутке [0,0.25)  -  ',s1);
  writeln('На промежутке [0.25,0.5)  -  ',s2);
  writeln('На промежутке [0.5,0.75)  -  ',s3);
  writeln('На промежутке [0.75,1)  -  ',s4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота