В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ektgdb
ektgdb
02.07.2021 19:01 •  Информатика

Напишите программу, которая спрашивала бы сокращенное имя, а печатала полное для пяти ваших друзей. ввод незнакомого имени должен провоцировать заявление типа «я с вами незнакома

Показать ответ
Ответ:
Mixail1510
Mixail1510
07.09.2020 23:19
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var names:array[1..2,1..5] of string:=
    (('Саша','Женя','Таня','Лена','Вася'),
    ('Александр','Евгений','Татьяна','Елена','Василий'));
  var name:=ReadlnString('Введите краткое имя:');
  var p:=0;
  for var i:=1 to 5 do
    if name=names[1,i] then begin p:=i; break end;
  if p>0 then Writeln(names[2,p])
  else Writeln('Я вас не знаю!')
end.

Тестовое решение
Введите краткое имя: Лена
Елена
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота