Напишите программу которая создаёт одномерный массив из 400 позиций заполняет его целыми случайными числами и считает количество честных и ннчётных значений. вывести результат подсчета
1) #include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a, b; printf("\n Введите первое число > "); scanf_s("%d", &a); printf("\n Введите второе число > "); scanf_s("%d", &b); if (a < b)printf("\n Второе число больше первого\n %d<%d\n",a,b); if (a > b)printf("\n Второе число меньше первого\n %d>%d\n", a, b); system("pause");}
2) Если я верно понял задание, то
#include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a; printf("\n Введите число > "); scanf_s("%d", &a); if (a > 0)printf("\n Число %d положительное\n", a); else printf("\n Число %d отрицательное\n", a); system("pause");}
3)
#include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); float a, b; int zn; printf("\n Введите a > "); scanf_s("%f", &a); printf("\n Введите b > "); scanf_s("%f", &b); printf("\n Для сложения a и b введите - 1"); printf("\n Для вычитания из числа a числа b - 2 "); printf("\n Для умножения a на b - 3 "); printf("\n Для умножения a на b - 4\n"); scanf_s("%d", &zn); if (zn == 1) printf("\n %5.2f+%5.2f=%5.2f", a, b, a + b); if (zn == 2) printf("\n %5.2f-%5.2f=%5.2f", a, b, a - b); if (zn == 3) printf("\n %5.2f*%5.2f=%5.2f", a, b, a*b); if (zn == 4) printf("\n %5.2f/%5.2f=%5.2f", a, b, a / b); printf("\n"); system("pause");}
4) #include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a; printf("\n Введите число > "); scanf_s("%d", &a); if ((a>0) && (a<=30))printf("\n Число приналежит диапозону от 1 до 30\n"); else printf("\n Число не принадлежит диапозону от 1 до 30\n"); system("pause");}
5) #include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a; printf("\n Введите число > "); scanf_s("%d", &a); if (a % 2 == 0)printf("\n Число четное\n"); else printf("\n Число нечетное\n"); system("pause");} 6) #include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a, i; printf("\n Введите число > "); scanf_s("%d", &a); if (a < 10)i = 1; if ((a < 100) && (a >= 10))i = 2; if ((a < 1000) && (a >= 100))i = 3; if ((a < 10000) && (a >= 1000))i = 4; if ((a < 100000) && (a >= 10000))i = 5; printf("\n В введенном числе %d цифр\n", i); system("pause");}
#include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a, b; printf("\n Введите первое число > "); scanf_s("%d", &a); printf("\n Введите второе число > "); scanf_s("%d", &b); if (a < b)printf("\n Второе число больше первого\n %d<%d\n",a,b); if (a > b)printf("\n Второе число меньше первого\n %d>%d\n", a, b); system("pause");}
2) Если я верно понял задание, то
#include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a; printf("\n Введите число > "); scanf_s("%d", &a); if (a > 0)printf("\n Число %d положительное\n", a); else printf("\n Число %d отрицательное\n", a); system("pause");}
3)
#include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); float a, b; int zn; printf("\n Введите a > "); scanf_s("%f", &a); printf("\n Введите b > "); scanf_s("%f", &b); printf("\n Для сложения a и b введите - 1"); printf("\n Для вычитания из числа a числа b - 2 "); printf("\n Для умножения a на b - 3 "); printf("\n Для умножения a на b - 4\n"); scanf_s("%d", &zn); if (zn == 1) printf("\n %5.2f+%5.2f=%5.2f", a, b, a + b); if (zn == 2) printf("\n %5.2f-%5.2f=%5.2f", a, b, a - b); if (zn == 3) printf("\n %5.2f*%5.2f=%5.2f", a, b, a*b); if (zn == 4) printf("\n %5.2f/%5.2f=%5.2f", a, b, a / b); printf("\n"); system("pause");}
4) #include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a; printf("\n Введите число > "); scanf_s("%d", &a); if ((a>0) && (a<=30))printf("\n Число приналежит диапозону от 1 до 30\n"); else printf("\n Число не принадлежит диапозону от 1 до 30\n"); system("pause");}
5) #include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a; printf("\n Введите число > "); scanf_s("%d", &a); if (a % 2 == 0)printf("\n Число четное\n"); else printf("\n Число нечетное\n"); system("pause");}
6)
#include <stdlib.h>#include <stdio.h>#include <locale>void main(){ setlocale(LC_ALL, "RUSSIAN"); int a, i; printf("\n Введите число > "); scanf_s("%d", &a); if (a < 10)i = 1; if ((a < 100) && (a >= 10))i = 2; if ((a < 1000) && (a >= 100))i = 3; if ((a < 10000) && (a >= 1000))i = 4; if ((a < 100000) && (a >= 10000))i = 5; printf("\n В введенном числе %d цифр\n", i); system("pause");}
//PascalABC.NET
uses GraphABC;
var c: integer;
begin
window.IsFixedSize := true;//запрет изменения размера экрана
window.Clear(cllightblue);//очистка экрана синим цветом
pen.Color := clred;//меняем цвет пера на красный
for var i := 0 to 19 do//цикл для отрисовки линий
begin
c := (window.Height div 19) * i;//сдвиг линнии по y
line(0, 0 + c, window.Width, window.Height - c);//рисуем линию
end;
end.
Объяснение:
uses graphabc;
begin
circle(50,50,50);
circle(50,50,20);
circle(150,50,50);
circle(150,50,20);
circle(250,50,50);
circle(250,50,20);
circle(350,50,50);
circle(350,50,20);
circle(450,50,50);
circle(450,50,20);
circle(550,50,50);
circle(550,50,20);
end.