В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Yaroslav34364
Yaroslav34364
11.04.2021 22:03 •  Информатика

Напишите программу, которая сортирует отдельно элементы массива с чётными и нечётными значениями. все элементы с нечётными значениями нужно отсортировать по возрастанию, а элементы с чётными значениями – по убыванию. при этом элементы каждой из групп (как чётные, так и нечётные) должны занимать то же множество позиций в массиве, что и до сортировки. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 100000 . выходные данные программа должна вывести все элементы отсортированного массива в одну строку, разделив их пробелами.

Показать ответ
Ответ:
ДианочкаР
ДианочкаР
07.09.2020 21:26
//Весьма слабое решение, но после перерыва мне простительно, хех.
//Pascal ABC.NET v3.1 сборка 1219

Var
 ar,arOdd,arNotOdd:array of integer;
 n,i,j,k1,k2:integer;
begin
 readln(n);
 setlength(ar,n+1);
 k1:=1;
 k2:=1;
 for i:=1 to n do
 begin
  readln(ar[i]);
  if odd(i) then
   begin
    setlength(arOdd,k1);
    arOdd[k1-1]:=ar[i];
    inc(k1);
   end
   else
   begin
    setlength(arNotOdd,k2);
    arNotOdd[k2-1]:=ar[i];
    inc(k2);
   end;
  end;
 sort(arOdd);
 sort(arNotOdd);
 reverse(arNotOdd);
 k1:=0;
 k2:=0;
 i:=0;
 while i<>n do
  begin
  inc(i);
   if odd(i) then
    begin
     ar[i]:=arOdd[k1];
     inc(k1);
    end
    else
    begin
     ar[i]:=arNotOdd[k2];
     inc(k2);
    end;
  write(ar[i],' ');
  end;
end.

Пример ввода:
5
1
2
3
4
5
Пример вывода:
1 4 3 2 5 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота