Напишите программу, которая считывает строку с числом nn, которое задаёт количество чисел, которые нужно считать. Далее считывает nn строк с числами x_ix
i
, по одному числу в каждой строке. Итого будет n+1n+1 строк.
При считывании числа x_ix
i
программа должна на отдельной строке вывести значение f(x_i)f(x
i
). Функция f(x) уже реализована и доступна для вызова.
Функция вычисляется достаточно долго и зависит только от переданного аргумента xx. Для того, чтобы уложиться в ограничение по времени, нужно избежать повторного вычисления значений.
Sample Input:
5
5
12
9
20
12
Sample Output:
11
41
47
61
41
Количество слов с ол можно подсчитать по той же схеме, если считать ол единой буквой. У нас остаётся буквы: Н, Б, Е, ИЙ, причём слово не может начинаться с Й. Количество таких слов равно 6*5*5*3*2*1=900. Всего возможных кодов получается 5400-900=4500.
Ответ: 4500.
Код программы:
var i, sum, a:integer;
begin
writeln('Четные числа:');
for i:= 72 to 134 do begin
if i mod 2 = 0 then
write(i, ' ');
end;
writeln();
writeln();
writeln('Числа, оканчивающиеся на "3":');
for i:= 72 to 134 do begin
if i mod 10 = 3 then
write(i, ' ');
end;
writeln();
writeln();
writeln('Числа, сумма цифр которых меньше 11:');
for i:= 72 to 134 do begin
a:= i;
sum:= 0;
while a <> 0 do begin
sum := sum + a mod 10;
a := a div 10;
end;
if sum < 11 then
write(i, ' ');
end;
end.