В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Напишите программу, которая считает знаки пунктуации в символьной строке. к знакам пунктуации относятся символы из набора «.,; : ! ? ». формат входных данных программа получает на вход символьную строку (длина строки не больше 100 символов). формат выходных данных программа должна вывести общее количество знаков пунктуации во входной строке. примеры входные данные выходные данные hi, guys! 2

Показать ответ
Ответ:
Nikita200111
Nikita200111
07.10.2020 02:40
Var s,p:string; k,i:integer;
begin
readln(s);
p:='.,;:!?';
k:=0;
for i:=1 to length(s) do
 if pos(s[i],p)>0 then k:=k+1;
writeln('k = ',k);
end.

Пример:
Hi, guys!
k = 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота