В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
nikkovalev199
nikkovalev199
18.07.2021 02:06 •  Информатика

Напишите программу, которая считает количество чётных цифр введённого числа. ---Входные данные---
Входная строка содержит одно натуральной число N .

---Выходные данные---
Программа должна вывести количество чётных цифр введённого числа.
ПРИМЕР
Ввод
123456
Вывод
3
Ввод
13579
Вывод
0
Желательно на Питоне или Паскале с использованием РЕКУРСИИ(фунции или процедуры)!

Показать ответ
Ответ:
ninayurova51
ninayurova51
07.01.2021 03:59

#include <iostream>  

using namespace std;

int main()

{

   long long a, sum = 0;

   cin >> a;

   while(a)

   {

       if((a%10) % 2)

           sum++;

       a/=10;

   }

   cout << sum << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота