В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Larka2017
Larka2017
29.01.2022 07:22 •  Информатика

Напишите программу, которая размещает случайным образом две ладьи на шахматной доске и определяет, бьют ли эти ладьи друг друга.

Показать ответ
Ответ:
12keti
12keti
26.05.2020 09:45

Язык СИ:

#include<stdio.h>

#include<stdlib.h>

#include<float.h>

#include<time.h>

int main(){

   

   srand(time(0));

   const long double cbc=64.0L-FLT_EPSILON;

   unsigned short int r1=cbc/RAND_MAX*rand(),

                                  r2=cbc/RAND_MAX*rand();

   

   printf("R1: %c%c\n",65+r1%8,49+r1/8);

   printf("R2: %c%c\n",65+r2%8,49+r2/8);

   printf("%s\n",r1%8==r2%8 || r1/8==r2/8?"yes":"no");

   

   return 0;

   

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота