В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kcenigolovaxa
kcenigolovaxa
20.05.2023 01:27 •  Информатика

Напишите программу, которая проверяет правильность имени переменной в языке паскаль. имя может содержать только латинские буквы (заглавные и строчные), цифры и знак подчёркивания, но не может начинаться с цифры. входные данные на вход программы подаётся символьная строка, содержащая имя переменной. выходные данные программа должна вывести ответ 'yes', если строка представляет собой правильное имя переменной в языке паскаль, и 'no', если имя ошибочно. примеры входные данные abc123 выходные данные yes входные данные abc[a! выходные данные no pascal abc 1.8 с использованием множеств

Показать ответ
Ответ:
likiad123
likiad123
05.10.2020 14:47
Var s: string;
    i: integer;
    good: boolean;
begin
readln(s);

good := True;
if (s[1] in ['0'..'9']) then
  good := False
else
begin
  for i := 1 to length(s) do
    if not ((s[i] in ['a'..'z']) or (s[i] in ['A'..'Z']) or (s[i] in ['0'..'9']) or (s[i] = '_')) then
      good := False;
end;

if (good) then
  writeln('YES')
else
  writeln('NO');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота