В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Рюзаки1
Рюзаки1
12.11.2022 14:47 •  Информатика

Напишите программу, которая проверяет, что каждая из трех целочисленных переменных вводится с клавиатуры положительно, в противном случае она создает соответствующую взаимосвязь.

Показать ответ
Ответ:
darya666666666666
darya666666666666
01.01.2023 16:39

=B8+$B25

Объяснение:

Столбцы в табличном процессоре размечены английский алфавитом: A B C D и так далее.

В ячейку С5 (столбец С, строка 5) вводят формулу "=А6+$В23", после чего копируют эту формулу в ячейку D7 (столбец D, строка 5) ⇒ эта ячейка находится справа на одно значение и на 2 строки вниз от ячейки C5 ⇒ В введенной формуле изменится значение первого аргумента "A6"  на "B8", второй аргумент находится в частичной заморозке (ячейка B заморожена - не изменяется при копировании, а строка ячейки - нет) ⇒ "B23" заменится на "B25"

0,0(0 оценок)
Ответ:
edomokurov
edomokurov
24.05.2022 05:19

#include <iostream>

using namespace std;

int main ()

{

   int salary;

   int quantity = 0;

   double amount = 0;

   double average_salary = 0;

   for (int i = 0; i < 5; i++)

   {

       cin >> salary;

       if (salary >= 0 && salary <= 80)

       {

           amount += salary;

           quantity++;

       }

   }

   average_salary = amount / quantity;

   cout << (average_salary);

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main ()

{

   int salary;  // Создание целочисленной переменной, отвечающей за вводимые с клавиатуры числа

   int quantity = 0;  // Создание целочисленной переменной, хранящей количество работников, попадающих под условие

   double amount = 0;  // Создание вещественной переменной для нахождения суммы зарплат, попадающих под условие

   double average_salary = 0;  // Создание вещественной переменной, хранящей среднюю зарплату

   for (int i = 0; i < 5; i++)  // Цикл выполняется 5 раз

   {

       cin >> salary;  // Вводим число с клавиатуры

       if (salary >= 0 && salary <= 80)  // Если 0 <= значение переменной salary <= 80

       {

           amount += salary;  // Сумма = сумма + вводимое число

           quantity++;  // К переменной, хранящей количество, прибавляем единицу

       }

   }

   average_salary = amount / quantity;  // Вычисление средней зарплаты: средняя зарплата = сумма ÷ количество

   cout << average_salary;  // Вывод ответа

}

0,0(0 оценок)
Популярные вопросы: Информатика
sini1
sini1
23.02.2022 15:20
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота