В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Masha6996
Masha6996
23.04.2022 15:09 •  Информатика

Напишите программу, которая принимает символьную строку, содержащую пароль пользователя. Программа должна сообщить является ли пароль надёжным. Критерии надёжности пароля:

1. Пароль должен содержать не менее 8 символов.

2. Пароль должен содержать заглавные и строчные буквы.

3. Пароль должен содержать цифры
Необходимо вывести строку «YES», если пароль надёжный, и строку «NO» в противном случае.

ВАЖНО!

Для решения задачи нужно использовать функции s.islower() и s.isupper()

Показать ответ
Ответ:
90Лилиана11111
90Лилиана11111
03.04.2022 19:01

Бит

Единицей измерения количества информации является бит – это наименьшая (элементарная) единица.

1бит – это количество информации, содержащейся в сообщении, которое вдвое уменьшает неопределенность знаний о чем-либо.

 

Байт

Байт – основная единица измерения количества информации.

Байтом называется последовательность из 8 битов.

Байт – довольно мелкая единица измерения информации. Например, 1 символ – это 1 байт.

 

Производные единицы измерения количества информации

1 байт=8 битов

1 килобайт (Кб)=1024 байта =210 байтов

1 мегабайт (Мб)=1024 килобайта =210 килобайтов=220 байтов

1 гигабайт (Гб)=1024 мегабайта =210 мегабайтов=230 байтов

1 терабайт (Гб)=1024 гигабайта =210 гигабайтов=240 байтов

Запомните, приставка КИЛО в информатике – это не 1000, а 1024, то есть 210 .

0,0(0 оценок)
Ответ:
MegaCrisp1
MegaCrisp1
01.01.2023 00:22
Вот программа : program xxx; 
<p>program xxx;</p><p>&nbsp;&nbsp; var i, k, d, e, s : integer;</p><p>begin</p><p>&nbsp; k:=0;</p><p>&nbsp;for i:= 10 to 99 do</p><p>&nbsp;&nbsp; begin</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; d:= i div 10;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; e:= i mod 10;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; s:=d + e;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; if i mod s = 0 then k:=k+1</p><p>&nbsp;&nbsp; end;</p><p>&nbsp;&nbsp; write ('кол-во чисел которые делятся на сумму своих цифр=', k);</p><p>&nbsp;&nbsp; readln</p><p>end.</p>
Найдите количество двузначных чисел, которые делятся на сумму своих цифр.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота