В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
karamanilya
karamanilya
12.02.2021 02:47 •  Информатика

(напишите программу которая преобразует угол из градусной меры в радианную. результат выводится на экран) в pascal abc

Показать ответ
Ответ:
vasiaska234
vasiaska234
30.08.2020 14:21
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',DegToRad(d))
end.

Тестовое решение:
Введите угол в градусах: 57.3
Угол в радианах: 1.00007364807695

Вариант с формулой вместо функции:
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',Pi*d/180)
end.

Вариант, если не хочется использовать константу Pi:
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',ArcTan(1)*d/45)
end.

Вариант для тех, кто не помнит, что arctg(1)=π/4:
//PascalABC.Net 3.0, сборка 1052
const
  Pi=3.14;
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',Pi*d/180)
end.

Тестовое решение для этого случая:
Введите угол в градусах: 57.3
Угол в радианах: 0.999566653357612

Как видно, из-за значения π, заданного с низкой точностью, снизилась и точность результата.
0,0(0 оценок)
Ответ:
DaryaMoh
DaryaMoh
30.08.2020 14:21
Var s:real;d:double;
begin 
Read(s);
d:= s*3.2425926/180;
write(s,' градусов = ',d,' радиан');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота