В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
veronik09
veronik09
11.06.2022 13:42 •  Информатика

Напишите программу, которая преобразует сумму денег (целое число), предоставленную пользователем, в минимально возможное количество монет и банкнот достоинством 1, 2, 5, 10, 20, 50 злотых. Кроме того, программа отображает количество всех банкнот и монет.

Показать ответ
Ответ:
эльза182
эльза182
08.11.2020 13:40

Объяснение:

#include <iostream>

int main()

{

   size_t sum, i = 0;

   const size_t nominals[] = { 5000, 2000, 1000, 500, 200, 100, 50, 10, 5, 2, 1 };

       

   std:cin >> sum;

   while(sum)

   {

       if (sum / nominals[i] > 0)

       {

           std::cout << nominals[i] << "  ";

           sum -= nominals[i];

       }

       else

           ++i;

   }

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота