В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
нина12789
нина12789
29.06.2022 08:24 •  Информатика

Напишите программу, которая предложит пользователю ввести длину строки n и ее члены-целые числа, и отобразит на экране следующую информацию: сам массив, среднее арифметическое всех четных чисел

Показать ответ
Ответ:
iriskaesipova
iriskaesipova
11.08.2020 11:01

javascript:var n = prompt("Введите n:"), массив = [], чётных = 0; for (let сч = 0; сч < n; сч++) массив.push(parseInt(prompt("["+сч+"]:"))); alert(массив + "\n" + (массив.reduce(function (пр, тек) { if (тек % 2 == 0) { чётных++; return пр + тек; } else return пр; }, 0) / чётных));

0,0(0 оценок)
Ответ:
eminememetova2
eminememetova2
11.08.2020 11:01

var a:array of integer;

n,i,s,k:integer;

begin

write('Введите количество элементов массива: ');

readln(n);

a:=new integer[n];

for i:=0 to n-1 do read(a[i]);

write ('Массив: ');

for i:=0 to n-1 do write(a[i],'  ');

writeln;

for i:=0 to n-1 do

if a[i]mod 2 = 0 then

begin

s:=s+a[i];

k:=k+1

end;

writeln('Среднее арифметическое чётных элементов массива равно: ',s/k:0:3)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота