В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
zaharsd
zaharsd
25.12.2022 15:58 •  Информатика

Напишите программу, которая позволяет пользователю загрузить слова из CSV, в случайном порядке показывает пользователю слово и перевод, позволяет добавить новые слова, позволяет сделать выгрузку в CSV. - Загрузка слов из CSV
- Случайный просмотр
-Добавление новых слов
- Выгрузка слов в CSV
- Exception

Показать ответ
Ответ:
Знаток228111
Знаток228111
05.01.2023 22:16

ЯП: С++

#include <iostream>

int main() {

const int N = 5;

int arr[N][N] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25}; // создаем и заполняем двумерный массив 5x5

for (int i = 0; i < N; i++) // выводим на экран 2-мерный массив;

{

 for (int j = 0; j < N; j++)

 {

  std::cout << arr[i][j] << "\t";

 }

 std::cout << std::endl;

}

std::cout << "Result #1: ";

for (int i = 0; i < N; i++) // вывод в консоль главной диагонали

{

 std::cout << arr[i][i] << "\t";

}

std::cout << "\nResult #2: ";

for (int i = 0; i < N; i++) // вывод в консоль побочной диагонали

{

 std::cout << arr[i][N - 1 - i] << "\t";

}

return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
шогвшвгвшр
шогвшвгвшр
05.04.2022 02:01

Смотри картинку

Объяснение:

Крестик - начало слова, стрелка - конец.

Абак - счётные доски для вычислений в Древней Греции, Древнем Риме, Древнем Китае и т.д.

Арифмометр - настольная или портативная механическая вычислительная машина.

Перфокарта - носитель информации. Тонкий картон с отверстиями или без них в определённых местах.

Транзистор - полупроводниковое устройство, которое используется для усиления, генерации и преобразования электрических сигналов. Транзисторы заменили вакуумные лампы в большинстве электронных устройств, свершив революцию в создании интегральных схем и компьютеров.

ЭНИАК – первая электронная вычислительная машина.

Бэббидж Чарлз - изобретатель первой аналитической вычислительной машины.

Лавлейс Ада - написала первые программы для аналитической вычислительной машины Беббиджа.

Лейбниц - предложил двоичную систему счисления, автор первой механической счётной машины производившей сложение, вычитание, умножение и деление чисел.

Возняк Стив - один из основателей компании Apple. Разработал первый массовый домашний компьютер и первый массовый персональный компьютер.

Холлерит Герман - создатель электрической статистической табулирующей системы (оборудования для работы с перфокартами).

Непер Джон - изобретатель логарифмов, для их вычисления он предложил устройство под названием «палочки Непера».

Шиккард Вильгельм - придумал «Считающие часы», первый арифмометр, умевший выполнять четыре арифметических действия.

Паскаль Блез - автор первой механической счётной машины, выполнявшей сложение и вычитание чисел. (Паскаль - один из наиболее известных языков программирования.)

Лебедева Сергей - под его руководством была создана МЭСМ (малая электронная счётная машина).


Сканворд на темуИВТ Нужно найти 14 слов
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота