В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Напишите программу, которая позволит проверять пароль на сложность. воспользуйтесь строковыми , описанными в разделе 4.7.1. string methods ( org/3.6/library/stdtypes.html#str.isupper). проверку пароля следует проводить по таким критериям: 1. длина: от 5 символов. 2. буквы латинского алфавита в верхнем и нижнем регистре: a, a, z, z. 3. цифры: от 0 до 9. 4. символы: @, #, %, & . 35

Показать ответ
Ответ:
gerl1999
gerl1999
26.12.2020 19:48
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=3;
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(k,6,-20,20);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var n:=ReadInteger('Какую строку удалить (1-'+k+')?');
  Assert(n.Between(1,k),'Введено неверное значение');
  var r:=a.Row(k-1); // последняя строка
  SetLength(a,k-1,a.ColCount); // теперь строк на одну меньше
  if n<k then begin
    for var i:=n-1 to k-3 do
      a.SetRow(i,a.Row(i+1));
    a.SetRow(k-2,r)
    end;
  Writeln(4*a.ColCount*'-'); a.Println(4)
end.

Примеры
*** Исходный массив ***
  -8   3 -10  -5  -8  11
  14  -5 -19  -6 -19 -15
   0 -11  11   3  -6 -12

Какую строку удалить (1-3)? 1

  14  -5 -19  -6 -19 -15
   0 -11  11   3  -6 -12

*** Исходный массив ***
  11 -14  -3  18  19  -9
 -11  19   8  20 -19  19
 -20  13   3 -13  13   1

Какую строку удалить (1-3)? 3

  11 -14  -3  18  19  -9
 -11  19   8  20 -19  19
0,0(0 оценок)
Ответ:
РенаКОСЫРЕВА
РенаКОСЫРЕВА
22.08.2022 13:26

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "");

int N = 10;

int max = -9999999;

int sum = 0;

int choise = 0;

int arr[N] = {0};

cout << "Введите 10 значений: ";

for(int i = 0; i<N; ++i) {

cin >> arr[i];

}

cout << "Введите действие (1 - +, 2 - макс. значение, 3 - колво отр. значений)";

cin >> choise;

if(choise==1) {

for(int i = 0; i<N; ++i) {

sum+=arr[i];

}

cout << endl << "Сумма: " << sum;

}

if(choise==2) {

for(int i = 0; i<N; ++i) {

if(arr[i]>max) {

max = arr[i];

}

}

 cout << endl << "Макс. знач: " << max;

}

if(choise==3) {

 for(int i = 0; i<N; ++i) {

   if(arr[i]<0) {

     ++sum;

   }

 }

 cout << "Колво отр. знач: " << sum;

}

 if(choise!=1&&choise!=2&&choise!=3) {

   cout << "Введите корректное значение.";

 }

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота