В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Werevolk1
Werevolk1
24.08.2021 09:03 •  Информатика

Напишите программу, которая получает от пользователя два числа a и b и печатает среднее арифметическое всех чисел из отрезка [a; b], которые делятся на 3.
программа на питоне

Показать ответ
Ответ:
veronikamihailova37
veronikamihailova37
28.08.2021 14:55

from statistics import mean

a = []

for i in range(int(input('a = ')), int(input('b = ')) + 1):

   if i % 3 == 0:

       a += [i]

print('Ср. арифм. всех чисел:', mean(a))


Напишите программу, которая получает от пользователя два числа a и b и печатает среднее арифметическ
0,0(0 оценок)
Ответ:
vladpaskevits
vladpaskevits
28.08.2021 14:55

a=int(input())

b=int(input())

mas=[i for i in range(a,b+1) if i%3==0]

print(sum(mas)/len(mas))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота