В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ckyka
Ckyka
27.09.2021 06:01 •  Информатика

Напишите программу, которая получает два целых числа (a и b) и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. формат входных данных в первой строке входных данных - два числа a и b (-10000 пробел формат выходных данных cтрока содержащее произведение чисел (см. пример вывода) пример входные данные выходные данные 10 -15 10*(-15)=-150

Показать ответ
Ответ:
nfz43616
nfz43616
07.10.2020 09:48
#include <cctype>  #include <algorithm>  #include <cmath>#include <iomanip>  #include <windows.h>#include <conio.h>#include <set>#include <iostream>  #include <string>  #include <vector>  using namespace std;
int main(){ int a, b,f=0,f1=0,ans=0; cin >> a >> b; if (a < 0 ) f = 1; if (b < 0) f1 = 1; for (int i = 0; i < abs(b);i++) { ans += a; } if (f == 1 && f1 == 1) cout << abs(ans); else if (f == 1 || f1 == 1) cout << '-' << abs(ans); else cout << ans; return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота