В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Леночка177
Леночка177
12.02.2021 18:24 •  Информатика

напишите программу которая подсчитывает количество цифр в натуральном числе N введённым с клавиатуры​

Показать ответ
Ответ:
cherbycorTaiga
cherbycorTaiga
15.11.2020 10:09

#include <iostream>

using namespace std;

typedef long long ll;

int main()

{

  ll number, i = 0;

  cin >> number;

  while(number > 0){

      number/=10;

      ++i;

  }

  cout << i;

}

// хитрый вариант с использованием строк на случай если число будет очень большое

#include <iostream>

#include <string>

using namespace std;

int main()

{

  string number;

  cin >> number;

  cout << number.size();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота