В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
люба358
люба358
17.09.2020 00:54 •  Информатика

Напишите программу: которая подсчитывает кол-во нечетных чисел больше 7 в последовательности состоящей из 15 чисел

Показать ответ
Ответ:
нигич1
нигич1
22.03.2020 18:14

x1 = int(input("Введите количество элементов в первом списке "))

#создаем пустые списки

m1 = []

m2 = []

m3 = []

for i in range(x1):

   m1.append(int(input()))

s1,s2,s3= 0,0,0 #переменные для сумм

for i in range(x1): #находим сумму элементов первого массива

   s1+= m1[i]

print("Сумма элементов первого списка равна:",s1)

print("Среднее арифметическое первого списка равно",s1/x1)

x2 = int(input("Введите количество элементов во втором списке "))

for j in range(x2):

   m2.append(int(input()))

for j in range(x2): #находим сумму элементов первого массива

   s2 += m2[j]

print("Сумма элементов второго списка равна:",s2)

print("Среднее арифметическое второго списка равно",s2/x2)

x3 = int(input("Введите количество элементов в третьем списке "))

for k in range(x3):

   m3.append(int(input()))

for k in range(x3): #находим сумму элементов первого массива

   s3 += m3[k]

print("Сумма элементов третьего списка равна:",s3)

print("Среднее арифметическое первого списка равно",s3/x3)

0,0(0 оценок)
Ответ:
alenaizmailova
alenaizmailova
20.04.2022 12:16

from turtle import *  # импортирую *встроенную(она скачана при

# установке питона) библиотеку turtle

# * для упрощения пр. до: turtle.комманда после: команда #

# (избавляемся от turtle. - заменяем

# *turtle.комманда() на просто *команда())

reset()  # очищаю экран (вдруг что-то случится)

t = Turtle()

t.hideturtle()  # не показывать курсор черепахи

screensize(800, 800, color('black'))  # расширение окна

# цвет

# numinput(заголовок, основной текст и т.д.) такая функция в turtle она просит пользователя ввести #число от minval до maxval - все задается

# иначе все выбирает (из цифр) (любое число пр. - 3054501210321)

color = numinput('Выберите цвет звезды: ',

               '1 - красный, 2 - желтый, 3 - синий',

               minval=1,  # минимальное значение

               maxval=3)  # максимальное значение

# условные операторы (выполняют действие при условии...)

if color == 1:

  color = t.color("red")

elif color == 2:

  color = t.color("yellow")

elif color == 3:

  color = t.color("blue")

# скорость и обновить экран

speed(0)  # 0 - самая быстрая, также как и 10, без разницы

update()

# функция (выполняется когда пишут имя_функции(и

# аргументы(size и т.п.) бывает и без них тогда просто пустое

# поле))

def draw_star(size):

  t.begin_fill()  # заполнить когда t.end_fill()

  # рисую

  angle = 144  # начальный луч

  # цикл (_ ставлю когда ничего не объявляю)

  for _ in range(5):  # 5 длинных сторон(оригинальный

      t.forward(size)  # нарисовать линии

      t.right(angle)  # и повернуть

  t.end_fill()

# смещаем на 300 вправо по x

t.left(180)

t.forward(200)

t.right(180)

# рисуем

draw_star(100 * 3)  # размер

# ну и обновлять экран пока True (всегда или до выхода

# пользователя из программы)

while True:

   update()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота