В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
птмпль
птмпль
04.01.2020 02:38 •  Информатика

Напишите программу, которая переводит переданное ей неотрицательное целое число в четырёхзначный шестнадцатеричный код, сохранив лидирующие нули. используйте процедуру. входные данные входная строка содержит неотрицательное целое число n ( 0 ≤ n < 16 4 ). выходные данные программа должна вывести четырёхзначный шестнадцатеричный код переданного её числа, сохранив лидирующие нули. используйте прописные латинские буквы.

Показать ответ
Ответ:
ДимаИванов11
ДимаИванов11
07.08.2020 12:44
Программа:
var n:integer;s:string;
procedure hex(a:integer; var h:string);
var i,m:integer; s1,s2:string;
begin
s2:='ABCDEF';
h:='';
for i:=1 to 4 do
 begin
 m:=a mod 16;
 case m of
  0..9   : str(m,s1);
  10..15 : s1:=s2[m-9];
 end;
 h:=s1+h;
 a:=a div 16;
 end;
end;
begin
write('n = '); readln(n);
hex(n,s);
writeln(n,'(10) = ',s,'(16)');
end.

Пример:
n = 4095
4095(10) = 0FFF(16)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота