В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
bogdan1001b
bogdan1001b
21.07.2020 00:25 •  Информатика

Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. используйте процедуру входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110

Показать ответ
Ответ:
555lina555
555lina555
17.07.2020 21:49
Procedure Dec2Bin(n: longint; var s: string);
var
  z: string;
  d: char;
begin
  s := '';
  if n < 0 then z := '-' else z := '';
  n := abs(n);
  while n > 0 do
  begin
    if (n mod 2) = 0 then d := '0' else d := '1';
    s := d + s;
    n := n div 2
  end;
  s := z + s;
  if s = '' then s := '0'
end;

var
  n: longint;
  s: string;

begin
  Write('Введите целое число: '); Readln(n);
  Dec2Bin(n, s);
  Writeln(s)
end.

Тестовое решение:
Введите целое число: -14
-1110
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота