Напишите программу, которая переводит число (возможно, отрицательное), записанное в шестнадцатеричной системе, в десятичную систему. входные данные входная строка содержит шестнадцатеричную запись числа n ( 1 ≤ | n | < 10 9 ). выходные данные программа должна вывести десятичную запись этого числа.
using namespace std;
int main()
{
int N;
setlocale(LC_ALL, "Russian");
cin >> hex >> N;
cout << N << endl;
system("pause");
return 0;
}
Пример:
27A9A
162458