В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
aasssddddddd
aasssddddddd
24.02.2023 13:46 •  Информатика

Напишите программу, которая определяете произведение кубов четных чисел от 5 до 100​

Показать ответ
Ответ:
1234567890love
1234567890love
23.11.2022 02:05

#include <iostream>

using namespace std;

int main()

{

   int line, column;

   cout << "Введите количество строк и столбцов через пробел: ";

   cin >> line >> column;

   int array[50][50] = {};

   cout << "Введите элементы двумерного массива: \n";

   for (int i = 0; i < line; i++ )

   {

       for (int j = 0; j < column; j++)

       {

           cin >> array[i][j];

       }

   }

   int max = array[0][1];

   int line_number = 1;

   for (int i = 0; i < line; i++)

   {

       int j = 1;

       if (max < array[i][j])

       {

           max = array[i][j];

           line_number = i + 1;

       }

   }

   cout << line_number;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

using namespace std;  // Пространство имен

int main()

{

  int line, column;  // Создание целочисленных переменных, отвечающих за количество строк и столбцов в двумерном массиве

  cout << "Введите количество строк и столбцов через пробел: ";  // Вывод сообщения в консоль

  cin >> line >> column;  // Ввод количества строк и столбцов с клавиатуры

  int array[50][50] = {};  // Создание целочисленного массива размером 50х50

  cout << "Введите элементы двумерного массива: \n";  // Вывод сообщения в консоль

  for (int i = 0; i < line; i++ )  // Цикл для ввода элементов массива

  {

      for (int j = 0; j < column; j++)  // Цикл для ввода элементов массива

      {

          cin >> array[i][j];  // Ввод элементов массива

      }

  }

   int max = array[0][1];  // Присваиваем переменной, хранящей максимум, значение массива в 0 строке и 1 столбце

   int line_number = 1;  // Переменная, хранящая номер строки

   for (int i = 0; i < line; i++)  // Цикл для прогона значений 2-го столбца

   {

       int j = 1;  // // Нужны значения определенного столбца ⇒ значение переменной j будет постоянным

       if (max < array[i][j])  // Если значение переменной max < значения массива i строки и j столбца

       {

           max = array[i][j];  // Значение переменной max = значению массива i строки и j столбца

           line_number = i + 1;  // Номер строки = индекс строки + 1 (т. к. индексация начинается с нуля)

       }

   }

   cout << line_number;  // Вывод ответа

}

0,0(0 оценок)
Ответ:
natalyabuben0111
natalyabuben0111
26.12.2020 01:31

Начнём с восьмеричной СС.

У нас имеется число 3712 в 8-чной СС.

Каждая цифра восьмеричной СС имеет свой двоичный код.

Первая цифра нашего числа - 3.

Она имеет двоичный код 011 в таблице триад.

Далее идёт цифра 7.

Она имеет двоичный код 111.

Затем идёт цифра 1.

Она имеет двоичный код 001.

Ну и в конце цифра 2.

Они имеет двоичный код 010.

Теперь просто записываем двоичный код по порядку.

011111001010. Вот так и получаем наше двоичное число. Первый ноль является незначащим, поэтому его можно не использовать в конечной записи двоичного кода.

Теперь из двоичной в 16-чную СС.

Нам нужно наше двоичное число разбить по 4-кам справа налево.

Получим:

0111 1100 1010

Также как и в таблице триад каждое число имеет свой двоичный код.

0111 = 7

1100 = C

1010 = A

Просто записываем по порядку:

7CA


как осуществить перевод чисел, используя алгоритм на основе триад и четверок. 3712 (8→2, 2→16) Объя
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота