Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
79185519305
07.11.2020 00:01 •
Информатика
Напишите программу которая определяет является ли заданное натуральное числом квадратом некоторого натурального числа
Показать ответ
Ответ:
mgatron
25.08.2020 16:20
Var
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln('YES')
else
writeln('NO');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ТахминаЖамалдинова
20.06.2020 14:53
4) Сколько восьмибуквенных кодов можно составить из символов + и - 5) Для передачи светового сигнала используются лампочки. Каждая лампочка имеет состояние горит или не горит . Какое...
arriiina
31.01.2020 20:01
Проверка попадания точки в заданную область. Записать логическое выражение, соответствующее заданной области истинности....
nisa89
29.07.2020 08:19
Составить резус для слова информация...
мама1035
04.04.2023 02:54
Напишите программу, которая определяет, является ли заданная строка правильным ip-адресом. на паскале...
zhenyaermakov
20.02.2021 22:11
КЛАСС! Тема: Метрические соотношения в прямоугольном треугольнике ВСЕГО 3 ЗАДАНИЯ ВСЕ НА ФОТО...
Анастасия221111
30.09.2021 21:13
определите температуру которую приобрёл газ , если начальное давление было 200 кПа, а столо 50кПа начальный объём был 5м^3, а стал 10м^3 начальная температура была 100⁰...
Den2228
28.02.2020 00:32
Берілген мәтіннің баяндау желісін сақтап, әр бөлігінен алынған ақпараттардан жинақы мәтін – аннотация жазыңыз....
RaidenGames
06.03.2022 17:22
Что может быть глаголом?(A) эльф; (Б) тролль; (в) гном; (Г) гоблин; (Д) ведьма....
Bikoshm
06.03.2022 17:22
Task 2 Tick the sentences where the word in bold is correct. If it`s wrong, write the correct word. 1 Do you want to meet at Tuesday? 2 Liza waited for Greg in an hour. 3 I`ll be home...
DarinaDoka666
25.01.2020 19:51
Используя формулу ПОПС, ответь на вопрос: Как вы думаете, советская власть благо или вред для крестьянина, рабочего, интеллигенции...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n, x: longint;
begin
readln(n);
x := round(sqrt(n));
if x * x = n then
writeln('YES')
else
writeln('NO');
end.