В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
danik24rysskiy
danik24rysskiy
22.01.2022 08:09 •  Информатика

Напишите программу которая определяет nod трех натуральных чисел (с использованием процедур)

Показать ответ
Ответ:
IvanBur2006
IvanBur2006
03.07.2020 08:46
Var
 a,b,c:integer;
procedure main(a,b,c:integer);
var
 i,max,nod:integer;
begin
 if (a>b) and (a>c) then
  max:=a
 else
  if (b>a) and (b>c) then
   max:=b
  else
   max:=c;
 nod:=1;
 for i:=1 to max do
 begin
  if (a mod i = 0) and (b mod i = 0) and (c mod i = 0) then
   nod:=i;
 end;
 writeln(nod);
end;
begin
 read(a,b,c);
 main(a,b,c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота