В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
divamurmyrlena
divamurmyrlena
07.03.2022 03:54 •  Информатика

Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. входные данные на вход программы подаётся символьная строка. выходные данные программа должна вывести количество различных символов в этой строке. примеры входные данные ab122ab выходные данные 5 pascal abc 1.8

Показать ответ
Ответ:
dimon2ru
dimon2ru
05.10.2020 14:33
Var used: Set of Char;
    s: string;
    i, cnt: integer;
    c: char;
begin
used := [];
readln(s);

for i := 1 to length(s) do
  include(used, s[i]);

cnt := 0;
for c := #0 to #255 do
  if (c in used) then
    cnt := cnt + 1;

writeln(cnt);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота