В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Напишите программу, которая определит какой процент состовляют буквы "а" во введеном тексте. ВНИМАНИЕ ЭТО НА C++, НЕ Pascal ​

Показать ответ
Ответ:
anton20063
anton20063
15.01.2021 21:25

#include <iostream>

#include <cmath>

using namespace std;

signed main()

{

   setlocale(LC_ALL, "Rus");

   int N;

   bool haveZero = false, haveOne = false;

   cin >> N;

   N = abs(N);

   while(N>0){

       if(N % 10 == 0)

           haveZero = true;

       if(N % 10 == 1)

           haveOne = true;

       N /= 10;

   }

   cout << "Наличие нуля: " << boolalpha << haveZero << endl;

   cout << "Наличие единицы в числе: " << boolalpha << haveOne << endl;

   return 0;

}

0,0(0 оценок)
Ответ:
slyzova1
slyzova1
20.04.2021 02:25

Відповідь:

Дивись фото

Пояснення:

<!DOCTYPE html>

<html>

<head>

  <title>Price</title>

  <meta charset="utf-8">

</head>

<body>

 <p>стоимости переговоров</p>

</body>

<script>

 {/*Написать логическое выражение для определения стоимости переговоров, если стоимость переговоров с 22 часов до 8 часов на 20% ниже, а в субботу и в воскресенье дополнительно предоставляется скидка 10%. */}

 t = +prompt('время разговоров от 0 до 24 часов')

 dt = +prompt('продолжительность разговора в минутах')

s = +prompt('стоимость минуты разговора')

 d = +prompt('день недели от 1 до 7')

 console.log('t=',t,'dt=', dt, 's=', s, 'd=', d)

 function Price (t, dt, d, s) {

  let startTalk = t*60

  let price = 0

  console.log('day = ', d)

 

  for (let i =1; i<=dt; i++){

   let night = false

   let holiday = false

   let p = s

   

   if( (startTalk+i)%1440 === 0 ){

    if (d<7){

     d=d+1

     console.log('day = ', d)

    } else {

     d=1

     console.log('day = ', d)

    }

   }

   if ( (startTalk+i)%1440>=1320 || (startTalk+i)%1440<480){

    night = true

   }

   if ( d === 6 || d===7){

    holiday = true

   }

   if (night){

    p = p - s*0.2

   

   }

   if (holiday){

    p = p-s*0.1

   }

   price = price+p

   

   console.log('стоимости '+ i+'мин. = '+ p.toFixed(2)+'$')

  }

  console.log('fin.price', price.toFixed(2), '$')

  return price.toFixed(2)

 }

 {/*Price(t, dt, d, s)*/}

 alert('стоимости переговоров  ' + '$' + Price(t, dt, d, s))

</script>

</html>


Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота