В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Oishahon
Oishahon
04.01.2023 15:38 •  Информатика

Напишите программу, которая определит, каких символов в последовательности
больше: четных или нечётных? Числа вводятся до ввода нуля.

Показать ответ
Ответ:
Афооня
Афооня
19.01.2021 17:02

ch,nch = 0,0

x = int(input())

while x != 0:

   if x != 0 and x % 2 == 0:

       ch += 1

   else:

       nch += 1

   x = int(input())

if ch > nch:

   print("Четных больше")

elif nch > ch:

   print("Нечетных больше")

else:

   print("Одинаково")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота