В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Марго22111
Марго22111
04.07.2021 22:20 •  Информатика

Напишите программу, которая находит все символы, встречающиеся в обеих переданных ей строках. входные данные на вход программы две символьные строки, каждая строка завершается символом "конец строки". выходные данные программа должна вывести все символы, которые встречаются в обеих строках, в порядке возрастания их ascii-кодов. если таких символов нет, нужно вывести слово 'no'. примеры входные данные qwerty asdqwhy выходные данные qwy входные данные qwerty 12345 выходные данные no pascal abc 1.8 программа должна быть составлена по теме множества

Показать ответ
Ответ:
Ilyas30rus
Ilyas30rus
05.10.2020 14:35
Var set1: Set of Char;
    set2: Set of Char;
    s1, s2: string;
    i: integer;
    done: boolean;
    c: char;
begin
set1 := [];
set2 := [];
readln(s1);
readln(s2);

for i := 1 to length(s1) do
  include(set1, s1[i]);

for i := 1 to length(s2) do
  include(set2, s2[i]);

done := False;
for c := #0 to #255 do
  if (c in set1) and (c in set2) then
  begin
    done := True;
    write(c);
  end;

if not done then
  write('NO');

writeln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота