В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Дезолька
Дезолька
12.03.2022 06:11 •  Информатика

Напишите программу, которая находит в массиве минимальный и максимальный элемент из чисел кратных 5, но не кратных 2. Входные данные

Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива.

Выходные данные

Программа должна вывести в одной строке минимальный и максимальный из исел кратных 5, но не кратных 2, разделив их пробелом. Если в массиве нет таких чисел, программа должна вывести два числа -5.

Пример входных данных

10

12 35 15 20 5 10 50 43 57 8

Пример выходных данных

5 35
Язык pascal abc

Показать ответ
Ответ:
Соря11
Соря11
27.04.2020 22:48

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

   setlocale(LC_ALL,"Russian");

   int s;

   cout << "Введите s: ";

   cin >> s;

   switch(s)

   {

       case 0: cout << "LOSE"; break;

       case 1: cout << "DRAW"; break;

       case 3: cout << "WIN"; break;

       default: cout << "Неверное число."; break;

   }

}

Объяснение:

#include <iostream>  // Библиотека ввода-вывода

#include <clocale>  // Библиотека локализации (возможно, будет работать без нее)

using namespace std;  // Пространство имён

int main()

{

   setlocale(LC_ALL,"Russian");  // Локализация (возможно, будет работать без нее)

   int s;  // Создание целочисленной переменной

   cout << "Введите s: ";  // Вывод текста в консоль

   cin >> s;  // Ввод переменной с клавиатуры

   switch(s)  // Принимает значение s

   {

       case 0: cout << "LOSE"; break;  // Если s = 0, то выводим LOSE

       case 1: cout << "DRAW"; break;  // Если s = 1, то выводим DRAW

       case 3: cout << "WIN"; break;  // Если s = 3, то выводим WIN

       default: cout << "Неверное число."; break;  // Если s не равно ни одному из трёх чисел, то выводим Неверное число

   }

}

0,0(0 оценок)
Ответ:
pavlovaalina453
pavlovaalina453
14.08.2022 11:03
# # Код на ruby 2.2.3p173
def LineUpArraySize(num)
    cur_size = 4
    while num > cur_size
        cur_size = 2 * cur_size + 8
    end
    cur_size = 2 * cur_size + 8
end

def getSpiralNeighbours(num)
    a = []
    a[0] = [0, 0]
    a[1] = [-1, 1]
    moves = [[1, 0], [0, -1], [-1, 0], [0, 1]]
    move_direction = 0
    side_size = 2
    cur_size = 1
    cycle = 1
    mode_direction = 0
    for i in 2..LineUpArraySize(num)
        new_num = Array.new(2)
        new_num[0] = a.last[0] + moves[move_direction][0]
        new_num[1] = a.last[1] + moves[move_direction][1]
        a[i] = new_num
        # p new_num
        cur_size += 1

        if cur_size == side_size
            cur_size = 1
            move_direction = (move_direction + 1) % 4
            side_size += 1 if move_direction % 2 == 0
            cycle += 1 if move_direction == 0
        end
    end

    a.each_with_index do |i,x|
        p [x, i] if (i[0]-a[num][0]).abs <= 1 and  (i[1]-a[num][1]).abs <= 1
    end
end

getSpiralNeighbours(1090)

Вывод (числа и условные координаты)
[962, [15, 16]]
[1089, [15, 17]]
[1090, [16, 17]]
[1091, [16, 16]]
[1224, [15, 18]]
[1225, [16, 18]]
[1226, [17, 18]]
[1227, [17, 17]]
[1228, [17, 16]]
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота