В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kpy4
kpy4
08.08.2020 15:48 •  Информатика

Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число -1, если ни один элемент не повторяется. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести максимальный повторяющийся элемент в массиве или число -1, если ни один элемент не повторяется.

Показать ответ
Ответ:
marystuart21
marystuart21
05.10.2020 08:00
Var 
 a:array [1..10000] of integer;
 i,n,a_max,c;
begin
 read(n);
 a_max:=0;
 c:=0;
 for i:=1 to n do 
 begin
  a[i] := random(100); // автозаполнение массива 
  print(a[i]);
  if a[i]>a_max then a_max:=a[i]; // поиск максимального элемента
 end;
 writeln;
 for i:=1 to n do 
  if a[i]=a_max then inc(c); // поиск повторяющихся элементов
 if c>=2 then write(a_max)
 else write(-1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота