В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Напишите программу, которая находит в массиве [12; 182] количество элементов, делящихся на 5, напечатать исходный массив.массив заполнить случайным образом. на языке питон.

Показать ответ
Ответ:
konfetka7510
konfetka7510
18.09.2021 18:59

Основные

Объяснение:

монитор - отображение видеоинформации

видеокарта - обработка и подача видеосигнала на монитор

клавиатура и мышь - ввод информации от пользователя

блок питания - распределение питания между внутренними устройствами

жёсткий диск - постоянная память компьютера

оперативная память - временная память компьютера

процессор - основные вычислительные операции

материнская плата - связыает все элементы между собой

куллер - охлаждает

системный блок - для крепления внутренних элементов

дополнительные устройства ввода: сд или двд приводы, сканер, тачпад на ноутах, сенсорные понели, вэбкамеры, микрофоны...

дополнительные устройства вывода: колонки или наушники + звуковая карта, принтеры, плоттеры, проэкторы..

Можно еще модем, но компьютер может работать и без него

0,0(0 оценок)
Ответ:
Лис489
Лис489
23.03.2020 03:21
Код PascalABC 3.0

uses GraphABC, Crt;
Var
x,y,t,v1,v2:integer;
C:word;
Begin
Write('Введите время работы светофора:  ');
ReadLn(t);
Write('Введите скорость зелёной машины: ');
ReadLn(v1);
Write('Введите скорость красной машины: ');
ReadLn(v2);
LockDrawing;
Repeat
ClearWindow;
Case (C div t) mod 3 of
0:SetBrushColor(clGreen);
1:SetBrushColor(clYellow);
2:SetBrushColor(clRed);
End;
Circle(-30+(WindowWidth div 2),-40+(WindowHeight div 2),10);

Case (C div t) mod 3 of
2:SetBrushColor(clGreen);
1:SetBrushColor(clYellow);
0:SetBrushColor(clRed);
End;
Circle(-40+(WindowWidth div 2),30+(WindowHeight div 2),10);
if C<65535 then C:=C+1
else C:=0;

SetBrushColor(clMedGray);
FillRect(0,20+(WindowHeight div 2),WindowWidth,-20+(WindowHeight div 2));
FillRect(20+(WindowWidth div 2),0,-20+(WindowWidth div 2),WindowHeight);

SetBrushColor(clGreen);
FillRect(-13+(WindowWidth div 2),-40+y,13+(WindowWidth div 2),y);
if ((x+v1<=(WindowWidth div 2)-20)or(x-40>=(WindowWidth div 2)+20)) then x:=x+v1
else
   Begin
   if ((y-40>=20+(WindowHeight div 2))or(y<=(WindowHeight div 2)-20)) then
      Begin
      if ((C div t) mod 3 = 2)or(x>(WindowWidth div 2)-20) then x:=x+v1
      End
   End;

if x>=WindowWidth+40 then x:=0;
SetBrushColor(clRed);
FillRect(-40+x,13+(WindowHeight div 2),x,-13+(WindowHeight div 2));
if (y+v2<=(WindowHeight div 2)-20)or(y-40>=(WindowHeight div 2)+20) then y:=y+v2
else
   Begin
   if (x-40>=20+(WindowWidth div 2))or(x<=(WindowWidth div 2)-20) then
      Begin
      if ((C div t) mod 3 = 0)or(y>(WindowHeight div 2)-20) then y:=y+v2
      End
   End;

if y>=WindowHeight+40 then y:=0;
Redraw
Until false;

End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота