Напишите программу, которая находит произведение двух наименьших чисел из последовательности натуральных чисел. программа получает на вход натуральные числа, количество чисел неизвестно (но не менее двух), ввод последовательности заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. значения чисел не превышают 30000. программа должна вывести одно число: произведение двух чисел, значения которых в данной последовательности наименьшие
//Версия 3.3.5, сборка 1650
begin
var a:=ReadSeqIntegerWhile(x->x<>0).ToList;
var m:=a.Min;
a.Remove(m);
write(m*a.Min);
end.