В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
amina318
amina318
04.04.2022 20:45 •  Информатика

Напишите программу которая находит минимальный из четных положительных элементов матрицы учтите что таких элементов в матрице может и не быть
c++ двумерные массивы​

Показать ответ
Ответ:
Сарфароз03
Сарфароз03
04.04.2021 18:07
Современный компьютер может обрабатывать числовую, текстовую, графическую, звуковую и видео информацию. Все эти виды информации в компьютере представлены в двоичном коде, т. е. используется всего два символа 0 и 1. Связано это с тем, что удобно представлять информацию в виде последовательности электрических импульсов: импульс отсутствует (0), импульс есть (1).

Такое кодирование принято называть двоичным, а сами логические последовательности нулей и единиц - машинным языком.

Какой длины должен быть двоичный код, чтобы с его можно было закодировать васе символы клавиатуры компьютера?

Достаточный алфавит

В алфавит мощностью 256 символов можно поместить практически все символы, которые есть на клавиатуре. Такой алфавит называется достаточным.

Т.к. 256 = 28, то вес 1 символа – 8 бит.

Единице в 8 бит присвоили свое название - байт.

1 байт = 8 бит.

Таким образом, информационный вес одного символа достаточного алфавита равен 1 байту.
Для измерения больших информационных объемов используются более крупные единицы измерения информации:

Единицы измерения количества информации:

1 байт = 8 бит

1 килобайт = 1 Кб = 1024 байта

1 мегабайт = 1 Мб = 1024 Кб

1 гигабайт = 1 Гб = 1024 Гб

Информационный объем текста
0,0(0 оценок)
Ответ:
rudens2007
rudens2007
31.12.2020 16:14
1) var n, odd, even, i, a: integer;
begin
odd:=0;
even:=1;
writeln ('Введите число N');
read(N);
writeln('Введите N целых чисел');
for i:=1 to N do
begin
read(a);
if (a mod 2 = 0) then even:=even*a
else odd:=odd+a;
end;
writeln('Произведение чётных чисел равно ', even);
writeln('Сумма нечётных чисел равна ', odd);
end.

2)var N, plus, minus, i: integer;
a: real;
begin
plus:=0;
minus:=0;
writeln ('Введите число N');
read(N);
writeln('Введите N чисел');
for i:=1 to N do
begin
read (a);
if(a > 0) then plus:=plus+1;
if (a < 0) then minus:=minus+1;
end;
writeln('Количество положительных чисел равно ', plus);
writeln('Количество отрицательных чисел равно ', minus);
if (plus<minus) then writeln ('Отрицательных больше чем положительных на ', minus-plus);
if (plus>minus) then writeln ('Положительных больше чем отрицательных на ', plus-minus);
if (plus=minus) then writeln ('Количество положительных равно количеству отрицательных');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота