В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ксюшка485456
ксюшка485456
14.04.2020 00:02 •  Информатика

Напишите программу,которая находит минимальный и максимальный элементы матрицы и их индексы
Python

Показать ответ
Ответ:
Добрыйдемон13
Добрыйдемон13
28.08.2020 11:48

min = 1

for i in range(0, len(matrix) ) :

for k in range(0,len(matrix[i])) :

 b = matrix[i][k]

 if b < min :

  ind =[i,k]

  min=b

max = 1

for i in range(0, len(matrix) ) :

for k in range(0,len(matrix[i])) :

 b2 = matrix[i][k]

 if b2 > max :

  ind2 =[i,k]

  max=b2

Объяснение:

min и max - временные переменные , используемые в цикле  

min - минимальное значение матрицы max - максимальное значение

matrix - собственно сама матрица

ind - массив хранящий индекс матрицы с минимальный значением

ind2 - массив хранящий индекс матрицы с максимальным значением

0,0(0 оценок)
Ответ:
KukolkaBaig
KukolkaBaig
28.08.2020 11:48

lst = [[int(_) for _ in input().split()] for p in range(int(input()))]

mx_ind, mn_ind, mn, mx = (0, 0), (0, 0), max(max(lst)), 0

for i in range(len(lst)):

   for j in range(len(lst[i])):

       if lst[i][j] < mn:

           mn = lst[i][j]

           mn_ind = (i, j)

       if lst[i][j] > mx:

           mx = lst[i][j]

           mx_ind = (i, j)

print(f'Наибольший: A[{mx_ind[0]}][{mx_ind[1]}] = {mx}')

print(f'Наименьший: A[{mn_ind[0]}][{mn_ind[1]}] = {mn}')

На первой строчке вводишь количество строк в матрице(1 число)

На следующих n строчках вводишь матрицу

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота