В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ahahahahahhahah
ahahahahahhahah
16.09.2022 04:50 •  Информатика

Напишите программу, которая находит квадрат произведения цифр введенного числа

Показать ответ
Ответ:
ника2569
ника2569
06.10.2020 09:16
Var a,p:integer;
begin
write('a = ');
readln(a);
a:=abs(a);
p:=1;
while a<>0 do
 begin
 p:=p*(a mod 10);
 a:=a div 10;
 end;
p:=p*p;
writeln('p = ',p);
end.

Пример:
a = 273
p = 1764
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота