В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
BarsegyanDiana70
BarsegyanDiana70
25.03.2020 22:28 •  Информатика

Напишите программу, которая, используя оператор repeat, которая считывает с клавиатуры вещественное число х и выводит на экран у= √ 2х.​

Показать ответ
Ответ:
vikammirkushaoz9agx
vikammirkushaoz9agx
19.09.2022 12:14

я надеюсь ты не будешь против, если я буду кидать всю программу

пишу на python

                       №1

#array заполнен по условию

even = 0

odd = 0

for elem in array:

        if elem % 2 == 0:

                 even += 1

        else:

                 odd += 1

print(even, odd)

                      №2

a)

Red Blue Yellow Purple

Red Blue Purple Yellow

Blue Red Purple Yellow

б)

for i in range(len(array)):

              for j in range(len(array) - 1):

                             if array[j] > array[j + 1]:

                                      array[j], array[j + 1] = array[j + 1], array[j]

print(*array)

                              №3

k = int(input())

array = array[:k] + array[k + 1:]

print(array)

0,0(0 оценок)
Ответ:
liteops04
liteops04
23.03.2021 17:38

Створіть проект, у якому вводяться значення елементів табличної величини із 7 цілих чисел у багаторядковому текстовому полі, обчислюється сума від’ємних з них і результат виводиться в напис. Збережіть проект у папці з іменем Завдання 6.2.1, створеній у вашій папці.

procedure TForm1.Button1Click (Sender: TObject);

var a: array [1..8] of integer;

i, s: integer;

begin

for i: = 1 to 7 do a[i]:= StrToInt(Memo1.Lines[i - 1]);

s:= 0;

for i:= 1 to 7 do if a[i] < 0 then s:= s + a[i];

Label1. Caption: = IntToStr(s);

end;

2. Створіть проект, у якому вводяться значення елементів табличної величини з 8 дійсних чисел у багаторядковому текстовому полі, визначається кількість з них, які більші за 5, і результат виводиться в напис. Збережіть проект у папці з іменем Завдання 6.2.2, створеній у вашій папці.

procedure TForm1.Button1Click (Sender: TObject);

var a: array [1..8] of real;

i, k: integer;

begin

for i:= 1 to 8 do a[i]:= StrToFloat(Memo1.Lines[i - 1]);

k:= 0;

for i:= 1 to 8 do

if a[i] > 5 then k:= k + 1;

Label 1.Caption:= IntToStr(k);

end;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота