В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
FACCE
FACCE
25.07.2020 09:50 •  Информатика

Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших).

Показать ответ
Ответ:
Urjdifk135
Urjdifk135
02.10.2020 12:43
Var
  n,k:integer;
begin
  Write('Укажите число и номер инвертируемого бита: ');
  Read(n,k);
  Writeln('Результат: ',n xor (1 shl k))
end.

Тестовое решение:
Укажите число и номер инвертируемого бита: 573 4
Результат: 557
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота