В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Oormeero
Oormeero
30.04.2022 02:50 •  Информатика

напишите программу, которая имитирует проверку пароля, придуманного пользователем. пользователь вводит пароль, потом ещё раз его же, для подтверждения.

если пароль, который ввёл пользователь (в первый раз) короче 8 символов, программа выводит "короткий! " и завершает свою работу
если пароль достаточно длинный, но введённый во второй раз пароль не совпадает с первым, программа выводит "различаются."
если же и эта проверка пройдена успешно, программа выводит "ok" (латинскими буквами).
формат ввода
две строки — первый и второй пароль, введенные пользователем.
формат вывода
одна строка — результат проверки пароля.
язык питон

Показать ответ
Ответ:
Nalalisa
Nalalisa
13.03.2022 14:48
Var - список переменных
переменные а,с присваивают тип integer, т.е. целые числа; b присваивает тип string, т.е строковый тип
begin - начало программы
readln - оператор ввода, окончание ln осуществляет переход на новую строку
str(a,b) - т.е. преобразовать данные числа в строку
переменная b так же присваивает тип строковый
Val(b,a,c) где: b- строка, а-результат, с-позиция с которой произошла ошибка преобразования или 0
writeln(а) - оператор вывода, окончание ln осуществляет переход на новую строку
end. - конец программы
0,0(0 оценок)
Ответ:
valeriaasoskova
valeriaasoskova
04.03.2021 19:42
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Кол-во элементов:');
  var a:=ArrRandomReal(n,-10,20); a.Println;
  Writeln('С округлением если |x|<1');
  for var i:=0 to n-1 do
    if abs(a[i])<1 then a[i]:=Round(a[i]);
  a.Println
end.

Тестовое решение:
Кол-во элементов: 10
-0.751956142835299 5.95022566427953 3.58861613254464 7.42331713783709 -4.75036238075717 -9.41228387384316 -0.700975591643235 3.85500546258642 -1.94321916994789 19.3021338336645
С округлением если |x|<1
-1 5.95022566427953 3.58861613254464 7.42331713783709 -4.75036238075717 -9.41228387384316 -1 3.85500546258642 -1.94321916994789 19.3021338336645
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота